Error Reported: 1610 SCCM Console is not getting open giving wmi error

Action taken to fix.

Step 1: validate SmsAdminUI.log Logs.

cminfra_20

Step 2: By seeing found console is not getting require connection.

Step 3: validate sql DB error logs and found requester has detached and attached database. so Below error reported in logs.

An error occurred in the Microsoft .NET Framework while trying to load assembly id 65539. The server may be running out of resources, or the assembly may not be trusted with PERMISSION_SET = EXTERNAL_ACCESS or UNSAFE. Run the query again, or check documentation to see how to solve the assembly trust issues. For more information about this error:

cminfra_20_sql

Step 4: Validate events and found many events are trier with An error occurred in the Microsoft .NET Framework while trying to load assembly id 65539. Below are the screen shot for reference.

cminfra_20_eventsl

By seeing all above error below are the solutions found

step 5: Manually reset the property to ON by running the following command against your CM database

ALTER DATABASE <ConfigMgr DB> SET TRUSTWORTHY ON

After follow steps console start working as normal if still issue validate below define points in note.

Note:
Point 1: Make sure that the database that was moved is owned by the SA account.
Point 2: Make sure that the Isolation Level value is set to READ_COMMITTED_SNAPSHOT. To check this value, run the following command: DBCC USEROPTIONS
Point 3: If the Isolation Level value is set to anything other than READ COMMITTED SNAPSHOT, run following commands in the given order:
ALTER DATABASE <ConfigMgr DB> SET ALLOW_SNAPSHOT_ISOLATION ON
ALTER DATABASE <ConfigMgr DB> SET READ_COMMITTED_SNAPSHOT ON

For Details Click Here with different issue but same solution work for wmi issue.

Happy Learning!!!

Thanks & Regards,
Haresh Hirani
Email: hiraniconfigmgr@outlook.com
Follow me: https://www.linkedin.com/in/hiraniconfigmgr

Advertisements